Outils pour utilisateurs

Outils du site


start:raspberry:maj

Mise à jour du raspberry Raspbian version jessie (8) vers stretch (9)

Connaitre la version de rasbian : cat /etc/debian_version

Raspbian : mise-à-jour jessie vers stretch

La mise-à-jour de rasbian sans réinstallation de tout le système est possible de jessie vers stretch.

Avant toute chose : FAITE UNE SAUVEGARDE …

  • faites une mise-à-jour de jessie soit en ligne de commande avec :
  • apt-get update suivi de apt-get upgrade
  • soit à partir de synaptic avec « Recharger », « Tout mettre à niveau » et « Appliquer ».
  • faite une copie de votre carte SD avec SD Card Copier du menu Accessoires.

Puis, il est nécessaire de remplacer toutes les occurences de jessie par stretch dans les deux fichiers

  • /etc/apt/sources.list

et

  • /etc/apt/sources.list.d/raspi.list.

Pour cela, vous pouvez soit utiliser un éditeur de texte comme vi, soit le faire directement via synaptic via les « Dépôts » du menu « Configuration » où en changeant toutes les occurences de jessie en stretch vous agirez sur les deux fichiers « sources.list » et « raspi.list » simultanément.

Réalisez ensuite le rafraîchissement de la liste des paquets vers stretch par :

apt-get update

et effectuez la mise-à-jour avec :

apt-get -y dist-upgrade

(sous Debian, un simple upgrade après update réaliserait une mise-à-jour partielle moins risquée si on a peu de mémoire ou des paquets problèmatiques. Cela permet de gérer manuellement les problèmes avant une mise-à-jour complète avec dist-upgrade ; qu’en est-il sous raspbian, je n ‘ai pas testé !)

Référence : https://www.framboise314.fr/raspbian-stretch-pour-le-raspberry-pi-est-disponible/

Lors de l'erreur apt-transport-https installed

Quand je lance sudo apt-get update, je reçois toujours “E: Le pilote de méthode / usr / lib / apt / methods / https est introuvable. N: Le paquet apt-transport-https est-il installé?”

Télécharger par sftp ( put …) les 3 paquets correspondant à la version de Debian (ici version 8.0 Jessie armhf) :

Ensuite ( dans l'ordre indiqué ) :

  1. - sudo dpkg -i libapt-pkg4.12_1.0.9.8.5_armhf.deb
  2. - sudo dpkg -i libcurl3-gnutls_7.38.0-4+deb8u15_armhf.deb
  3. - sudo dpkg -i apt-transport-https_1.0.9.8.3_armhf.deb

Mise à niveau de stretch (9) vers buster (10)

  1. - FAITE UNE SAUVEGARDE …
  2. - cat /etc/debian_version ## vérifier la version
  3. - sudo apt-get -y update ## mise à jour de la liste des paquets
  4. - sudo apt-get -y upgrade ## mettre à jour la version actuelle
  5. - sudo reboot
  6. - ## remplacer toutes les occurrences de stretch par buster dans les deux fichiers sources.list et sources.list.d/raspi.list
  7. - sudo nano /etc/apt/sources.list
  8. - sudo nano /etc/apt/sources.list.d/raspi.list
  9. - sudo apt-get -y update ## mise à jour de la liste des paquets
  10. - sudo apt-get -y upgrade ## passer la version 10 buster 1ere etape
  11. - cat /etc/debian_version ## vérifier la nouvelle version

Avant de passer à la version complète vérifier si tout fonctionne et refaite une sauvegarde

  1. - sudo apt-get -y dist-upgrade ## Passer à la version complete de Buster Debian 10 2 eime etape
  2. - sudo reboot
  3. - verifier si tout fonctionne
start/raspberry/maj.txt · Dernière modification: 2020/08/26 19:07 (modification externe)